# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Za-z0-9-]+)(\.md)/2022-01-01-$1$2/gm;t' <<< "./src/content/posts/commit-without-file-changes-in-git.md"