re = /([A-Za-z0-9-]+)(\.md)/m
str = './src/content/posts/commit-without-file-changes-in-git.md'
subst = '2022-01-01-$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result