const regex = /([A-Za-z0-9-]+)(\.md)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Za-z0-9-]+)(\\.md)', 'gm')
const str = `./src/content/posts/commit-without-file-changes-in-git.md`;
const subst = `2022-01-01-$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);