// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Za-z0-9-]+)(\.md)").unwrap();
let string = "./src/content/posts/commit-without-file-changes-in-git.md";
let substitution = "2022-01-01-$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}