#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([A-Za-z0-9-]+)(\.md)"
Local $sString = "./src/content/posts/commit-without-file-changes-in-git.md"
Local $sSubst = "2022-01-01-$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)