use strict;
my $str = './src/content/posts/commit-without-file-changes-in-git.md';
my $regex = qr/([A-Za-z0-9-]+)(\.md)/mp;
my $subst = '2022-01-01-$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";