#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(-[0-9a-f]{32})"
Local $sString = "iPhone6Plus-learn_multi_child-0dfb2dc71fe20da66ca47190d3136b12.png"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)