package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(-[0-9a-f]{32})`)
var str = `iPhone6Plus-learn_multi_child-0dfb2dc71fe20da66ca47190d3136b12.png`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}