const regex = new RegExp('(-[0-9a-f]{32})', 'g')
const str = `iPhone6Plus-learn_multi_child-0dfb2dc71fe20da66ca47190d3136b12.png`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);