// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(-[0-9a-f]{32})").unwrap();
let string = "iPhone6Plus-learn_multi_child-0dfb2dc71fe20da66ca47190d3136b12.png";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}