re = /(-[0-9a-f]{32})/
str = 'iPhone6Plus-learn_multi_child-0dfb2dc71fe20da66ca47190d3136b12.png'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result