$re = '`(-[0-9a-f]{32})`';
$str = 'iPhone6Plus-learn_multi_child-0dfb2dc71fe20da66ca47190d3136b12.png';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;