use strict;
my $str = 'iPhone6Plus-learn_multi_child-0dfb2dc71fe20da66ca47190d3136b12.png';
my $regex = qr`(-[0-9a-f]{32})`p;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";