using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-[0-9a-f]{32})";
string substitution = @"";
string input = @"iPhone6Plus-learn_multi_child-0dfb2dc71fe20da66ca47190d3136b12.png";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}