# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/version(\s?)=(\s?)".*"/version$1=$2"0.1.0"/gm;t' <<< "version=\"0.1.0\""