using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"version(\s?)=(\s?)"".*""";
string substitution = @"version$1=$2""0.1.0""";
string input = @"version=""0.1.0""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}