$re = '/version(\s?)=(\s?)".*"/m';
$str = 'version="0.1.0"';
$subst = "version$1=$2\"0.1.0\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;