use strict;
my $str = 'version="0.1.0"';
my $regex = qr/version(\s?)=(\s?)".*"/mp;
my $subst = 'version$1=$2"0.1.0"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";