// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)version(\s?)=(\s?)".*""#).unwrap();
let string = "version=\"0.1.0\"";
let substitution = "version$1=$2\"0.1.0\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}