const regex = /version(\s?)=(\s?)".*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('version(\\s?)=(\\s?)".*"', 'gm')
const str = `version="0.1.0"`;
const subst = `version$1=$2"0.1.0"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);