import Foundation
let pattern = #"version(\s?)=(\s?)".*""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"version="0.1.0""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"version$1=$2"0.1.0""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)