# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*_([^.[:space:]]+).*/\1/gm;t' <<< "617912568590104527563-Congress-Dem-Packages_Nomination-DC2019-08-08.xlsx
517912568590504527553-Dem-Plans-Packages_Debate2019-08-08.xlsx
47912568590104527523-Congress-Dem-Packages_House2019-08-08 (1).xlsx"