$re = '~.*_([^.[:space:]]+).*~m';
$str = '617912568590104527563-Congress-Dem-Packages_Nomination-DC2019-08-08.xlsx
517912568590504527553-Dem-Plans-Packages_Debate2019-08-08.xlsx
47912568590104527523-Congress-Dem-Packages_House2019-08-08 (1).xlsx';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;