import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*_([^.[:space:]]+).*";
final String string = "617912568590104527563-Congress-Dem-Packages_Nomination-DC2019-08-08.xlsx\n"
+ "517912568590504527553-Dem-Plans-Packages_Debate2019-08-08.xlsx\n"
+ "47912568590104527523-Congress-Dem-Packages_House2019-08-08 (1).xlsx";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}