using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*_([^.[:space:]]+).*";
string substitution = @"\1";
string input = @"617912568590104527563-Congress-Dem-Packages_Nomination-DC2019-08-08.xlsx
517912568590504527553-Dem-Plans-Packages_Debate2019-08-08.xlsx
47912568590104527523-Congress-Dem-Packages_House2019-08-08 (1).xlsx";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}