package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*_([^.[:space:]]+).*`)
var str = `617912568590104527563-Congress-Dem-Packages_Nomination-DC2019-08-08.xlsx
517912568590504527553-Dem-Plans-Packages_Debate2019-08-08.xlsx
47912568590104527523-Congress-Dem-Packages_House2019-08-08 (1).xlsx`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}