// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*_([^.[:space:]]+).*").unwrap();
let string = "617912568590104527563-Congress-Dem-Packages_Nomination-DC2019-08-08.xlsx
517912568590504527553-Dem-Plans-Packages_Debate2019-08-08.xlsx
47912568590104527523-Congress-Dem-Packages_House2019-08-08 (1).xlsx";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}