import Foundation
let pattern = #".*_([^.[:space:]]+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
617912568590104527563-Congress-Dem-Packages_Nomination-DC2019-08-08.xlsx
517912568590504527553-Dem-Plans-Packages_Debate2019-08-08.xlsx
47912568590104527523-Congress-Dem-Packages_House2019-08-08 (1).xlsx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)