# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n[\s\S]*//g;t' <<< "Nov. 3, 2016
\t\t\t
\t\t\t
\t\t\t\tBO"