use strict;
my $str = 'Nov. 3, 2016
\\t\\t\\t
\\t\\t\\t
\\t\\t\\t\\tBO';
my $regex = qr/\n[\s\S]*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";