// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\n[\s\S]*").unwrap();
let string = "Nov. 3, 2016
\\t\\t\\t
\\t\\t\\t
\\t\\t\\t\\tBO";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}