const regex = /\n[\s\S]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n[\\s\\S]*', 'g')
const str = `Nov. 3, 2016
\\t\\t\\t
\\t\\t\\t
\\t\\t\\t\\tBO`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);