import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n[\\s\\S]*";
final String string = "Nov. 3, 2016\n"
+ " \\t\\t\\t\n"
+ "\\t\\t\\t\n"
+ "\\t\\t\\t\\tBO";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}