#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<a [^>]*href="(https://google\.com/[^"]*).+?</a>"
Local $sString = "<a href="https://yandex.ru/link1">Яндекс Link1</a>" & @CRLF & _
"<a href="https://yandex.ru/link2">Link2 Яндекс</a>" & @CRLF & _
"" & @CRLF & _
"<a href="https://google.com/link1">Google Link1</a>" & @CRLF & _
"<a href="https://google.com/link2">Link2 Google</a>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")