// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)<a [^>]*href="(https://google\.com/[^"]*).+?</a>"#).unwrap();
let string = "<a href=\"https://yandex.ru/link1\">Яндекс Link1</a>
<a href=\"https://yandex.ru/link2\">Link2 Яндекс</a>
<a href=\"https://google.com/link1\">Google Link1</a>
<a href=\"https://google.com/link2\">Link2 Google</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}