const regex = new RegExp('<a [^>]*href="(https://google\\.com/[^"]*).+?</a>', 'gis')
const str = `<a href="https://yandex.ru/link1">Яндекс Link1</a>
<a href="https://yandex.ru/link2">Link2 Яндекс</a>
<a href="https://google.com/link1">Google Link1</a>
<a href="https://google.com/link2">Link2 Google</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}