$re = '~<a [^>]*href="(https://google\.com/[^"]*).+?</a>~is';
$str = '<a href="https://yandex.ru/link1">Яндекс Link1</a>
<a href="https://yandex.ru/link2">Link2 Яндекс</a>
<a href="https://google.com/link1">Google Link1</a>
<a href="https://google.com/link2">Link2 Google</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);