using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a [^>]*href=""(https://google\.com/[^""]*).+?</a>";
string input = @"<a href=""https://yandex.ru/link1"">Яндекс Link1</a>
<a href=""https://yandex.ru/link2"">Link2 Яндекс</a>
<a href=""https://google.com/link1"">Google Link1</a>
<a href=""https://google.com/link2"">Link2 Google</a>
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}