package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<a [^>]*href="(https://google\.com/[^"]*).+?</a>`)
var str = `<a href="https://yandex.ru/link1">Яндекс Link1</a>
<a href="https://yandex.ru/link2">Link2 Яндекс</a>
<a href="https://google.com/link1">Google Link1</a>
<a href="https://google.com/link2">Link2 Google</a>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}