import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a [^>]*href=\"(https://google\\.com/[^\"]*).+?</a>";
final String string = "<a href=\"https://yandex.ru/link1\">Яндекс Link1</a>\n"
+ "<a href=\"https://yandex.ru/link2\">Link2 Яндекс</a>\n\n"
+ "<a href=\"https://google.com/link1\">Google Link1</a>\n"
+ "<a href=\"https://google.com/link2\">Link2 Google</a>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}