import Foundation
let pattern = #"<a [^>]*href="(https://google\.com/[^"]*).+?</a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<a href="https://yandex.ru/link1">Яндекс Link1</a>
<a href="https://yandex.ru/link2">Link2 Яндекс</a>
<a href="https://google.com/link1">Google Link1</a>
<a href="https://google.com/link2">Link2 Google</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)