re = /<a [^>]*href="(https:\/\/google\.com\/[^"]*).+?<\/a>/i
str = '<a href="https://yandex.ru/link1">Яндекс Link1</a>
<a href="https://yandex.ru/link2">Link2 Яндекс</a>
<a href="https://google.com/link1">Google Link1</a>
<a href="https://google.com/link2">Link2 Google</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end