#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$"
Local $sString = "123" & @CRLF & _
"129" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"67" & @CRLF & _
"113" & @CRLF & _
"4095" & @CRLF & _
"4096" & @CRLF & _
"4099" & @CRLF & _
"402" & @CRLF & _
"4091" & @CRLF & _
"1021" & @CRLF & _
"1211" & @CRLF & _
"4032" & @CRLF & _
"4089" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")