// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$").unwrap();
let string = "123
129
1
2
67
113
4095
4096
4099
402
4091
1021
1211
4032
4089
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}