$re = '/^([0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$/m';
$str = '123
129
1
2
67
113
4095
4096
4099
402
4091
1021
1211
4032
4089
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);