package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$`)
var str = `123
129
1
2
67
113
4095
4096
4099
402
4091
1021
1211
4032
4089
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}