use strict;
my $str = '123
129
1
2
67
113
4095
4096
4099
402
4091
1021
1211
4032
4089
';
my $regex = qr/^([0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}