import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$";
final String string = "123\n"
+ "129\n"
+ "1\n"
+ "2\n"
+ "67\n"
+ "113\n"
+ "4095\n"
+ "4096\n"
+ "4099\n"
+ "402\n"
+ "4091\n"
+ "1021\n"
+ "1211\n"
+ "4032\n"
+ "4089\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}