# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$"
test_str = ("123\n"
"129\n"
"1\n"
"2\n"
"67\n"
"113\n"
"4095\n"
"4096\n"
"4099\n"
"402\n"
"4091\n"
"1021\n"
"1211\n"
"4032\n"
"4089\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.