const regex = /^([0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$', 'gm')
const str = `123
129
1
2
67
113
4095
4096
4099
402
4091
1021
1211
4032
4089
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}